Jump to content


Photo
- - - - -

B36 aaaarrrgghhh


  • Please log in to reply
8 replies to this topic

#1 Glynn

Glynn

    Member

  • Sergeant
  • 116 posts
  • LocationUK

Posted 14 March 2017 - 07:08 PM

Help

I am having trouble with a b36 it ticks over nicely but when throttle is opened it dies.
I have the carburettor apart about 20 times and everything looks ok.

I have a spring missing from vacuum piston but have tried a stronger one and none and same problem.

Hjälpa

Jag har problem med en b36 det tömma över fint men när gaspådrag det dör.
Jag har förgasaren isär ca 20 gånger och allt ser ok.

Jag har en fjäder saknas vakuumkolven men har provat en starkare en och ingen och samma problem.
cheers Glynn

#2 Vinkon

Vinkon

    Member

  • Moderators
  • 3,869 posts
  • Location60 mil från verkligheten...

Posted 15 March 2017 - 01:21 PM

How about force-feeding the carb with fuel in order to rule out fuel depravation?

Just a thought
  • Glynn likes this

Bult: En cylindrisk kropp utan gängor.
Källa: NE & SAOL

 

Min Bv202  -  Mitt Hemmabygge


#3 eile

eile

    Member

  • Major
  • 1,341 posts
  • Locationvärnamo

Posted 15 March 2017 - 05:32 PM

Put up some photos,  is it a carter?    Old fuelpump with the one with glas cup enught fuel pressure check the backvale. 


  • Glynn likes this

#4 Glynn

Glynn

    Member

  • Sergeant
  • 116 posts
  • LocationUK

Posted 15 March 2017 - 06:53 PM

You can see he accelerator pump squirting fuel in so I wouldn't think starvation. I was thinking maybe too much fuel.
Yeah carter wgd. Pump appears ok .
I am pulling what little hair I have out.
cheers Glynn

#5 eile

eile

    Member

  • Major
  • 1,341 posts
  • Locationvärnamo

Posted 15 March 2017 - 07:03 PM

Are you sure it fuel problem?  To littel gap on contact breaker can give same symptom when vaccum move them or to bad spark if ingition coil are bad/hot.


  • Glynn likes this

#6 Glynn

Glynn

    Member

  • Sergeant
  • 116 posts
  • LocationUK

Posted 15 March 2017 - 07:42 PM

Points gap and spark is good
cheers Glynn

#7 Wingflyer

Wingflyer

    Member

  • Administrators
  • 2,377 posts
  • LocationEslöv

Posted 15 March 2017 - 08:41 PM

A leaking intake manifold will sometimes cause backfiring when the gas pedal is pressed from idle. Same symptom as a faulty carb acc pump...


  • Glynn likes this

TGB11 x2, TGB1314, Ambulanshytt 1315, TGB30 med stabshytt, TGB40 med 6 ton kran, TGB40 snart med krokväxlare, Startbil TL12, AmLastbil 806, 939 Viking med kran, Bv202, Snöslunga m/64 (Scania DS11 slungmotor på Volvo 939 chassi), North American T-28B :)


#8 Einhead

Einhead

    Member

  • Fänrik
  • 176 posts
  • LocationLinköping.

Posted 21 March 2017 - 07:29 AM

Tie the redicilous attempt to emission Control open..  There is an axle through the intake manifold with an butterfly valve in each intake opening that reroutes some air through a slightly longer path..  that axle is moved by a cam..  use a metal wire and tie it open.. That should improve the situation to some extent..

 

It is supposed to make the fuelburn leaner/better somehow..  I had the situation when the Engine was hot..it always started to detonate when moving from idle to full load when hot..

 

Anyway.. this is an easy thing to try for troubleshoting..

 

/ E


  • Glynn and Vinkon like this

#9 Glynn

Glynn

    Member

  • Sergeant
  • 116 posts
  • LocationUK

Posted 25 March 2017 - 06:16 PM

Thanks einhead I will look at that . I must say that I did not notice this valve, where is it on the manifold?
Thanks Glynn
cheers Glynn




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users